Project

General

Profile

Bug #34

synapse

Added by Bearcat Sandor about 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
High
Category:
Core
Target version:
-
Start date:
02/14/2012
Due date:
% Done:

100%

Estimated time:

Description

Hey there Arnud,

When i bring up the synapse application (it's like gnomedo without all the gnome dependencies) the transparancy is not being handled correctly. It's probably not confined to synapse, there are probably other apps for which this is a problem as well. Also, when i start up xorg/awesome the screen is black, and i have to move the terminal window around to refresh those areas.

Screen shots attached. Let me know how i can help you debug this.

Thanks!!

gentoo kernel 3.2.1
x86_64 intel core 2 quad Q9300 8g ram
xorg 1.11.2-r2
nvidia-drivers: 290.10
nvidia 8800 GT


Files

unagi_at_startup.png (41.3 KB) unagi_at_startup.png at start up need to move object over wall paper to see it and terminal window is black until clicked on Bearcat Sandor, 02/14/2012 03:38 AM
no_compmgr_with_synapse.png (245 KB) no_compmgr_with_synapse.png synapse with no comp manager (this looks correct) Bearcat Sandor, 02/14/2012 03:38 AM
xcompmgr_with_synapse.png (230 KB) xcompmgr_with_synapse.png synapse with xcompmgr (this looks correct) Bearcat Sandor, 02/14/2012 03:38 AM
unagi_with_synapse.png (227 KB) unagi_with_synapse.png synapse with unagi (this is incorrect. The black areas around the dialog should be transparent Bearcat Sandor, 02/14/2012 03:38 AM
2013-03-09-011117_1366x768_scrot.png (1.62 MB) 2013-03-09-011117_1366x768_scrot.png screenshot Toby Smithe, 03/09/2013 02:12 AM

Associated revisions

Revision db92a692 (diff)
Added by Arnaud Fontaine about 9 years ago

Handle windows with alpha mask already defined (closes #34).

Some applications such as Synapse or Gnome volume control behaves differently
when a Compositing Manager is active by defining themselves the alpha mask.

Reported-by: Bearcat M. Sandor <>

History

#1

Updated by Arnaud Fontaine about 9 years ago

  • Category set to Core
  • Assignee set to Arnaud Fontaine
  • Priority changed from Normal to High

Thank you very much for your bug report.

About synapse, after checking it seems that gnome volume has the same problem as rounded corners are not displayed properly. I will look into that and get back to you then.

About the startup issue, as with the latest release (0.3), I cannot reproduce this issue, I think I would need further information ;-). Do you get any warning messages from Unagi? Also could you please attach your configuration or command line for rxvt? Does it only happen with rxvt? How did you set the background? Could you please tell me which version/commit of Unagi you're using?

#2

Updated by Arnaud Fontaine about 9 years ago

I have split up this issue in two separate issues, one about Synapse (this one) and another one for the startup issue. Feel free to comment about the startup issue on #35. Many thanks!

#3

Updated by Arnaud Fontaine about 9 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
#4

Updated by Toby Smithe about 8 years ago

Hi,

I'm suffering a similar/the same problem using version 0.3.3 in Ubuntu raring, under the i3 window manager. I've attached a screenshot, showing synapse with visual artifacts, the i3bar, and a transparent cairo-clock.

Is there anything else I should provide to help you?

Cheers,

Toby

#5

Updated by Toby Smithe about 8 years ago

Actually, it seems to have been a bug in i3 itself, and is fixed in the development branch there. Sorry to bother you!

Also available in: Atom PDF