Project

General

Profile

Bug #44

Unagi fail to apply alpha mask for Wibox in AwesomeWM

Added by Emmanuel Lepage Vallee over 7 years ago. Updated over 7 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/24/2012
Due date:
% Done:

0%


Description

Hi,

I have seen there is new work on unagi, so I took some time to try it. To make some test, I tried to prototype this
http://kde-look.org/content/show.php/BeClock?content=117542
and this
http://rmbiggs.files.wordpress.com/2010/06/ipaddropdownmenu2.png?w=630

Both failed. The menu regressed from non composited awesome while the "clock" prototype show a dark square when opacity is enabled. It have been tested in Awesome 3.4.11.

Screenshots (with and without unagi) and code is attached to this bug

(ps: the blue square and arrows are there only when dragging a client with tabbar, I show them only to point you that the arrow alpha mask is fine, somehow)

blender125.png View - Without compositing (236 KB) Emmanuel Lepage Vallee, 03/24/2012 08:16 PM

blender126.png View - With compositing (259 KB) Emmanuel Lepage Vallee, 03/24/2012 08:16 PM

menuDeco.lua - DropDown menu prototype (1.98 KB) Emmanuel Lepage Vallee, 03/24/2012 08:16 PM

overlay.lua - Overlay clock prototype (1.82 KB) Emmanuel Lepage Vallee, 03/24/2012 08:16 PM

History

#1 Updated by Arnaud Fontaine over 7 years ago

Thanks for your bug report. Which version of unagi are you using? I will try to reproduce the issue and get back to you...

#2 Updated by Emmanuel Lepage Vallee over 7 years ago

Git master (e0cb268998e4e9e1b0ff6963eab4321d95fbbc4c)

Also available in: Atom PDF